1. Questo sito utilizza i cookies. Continuando a navigare tra queste pagine acconsenti implicitamente all'uso dei cookies. Scopri di più.
  2. Vuoi sostenere in prima persona il forum? Iscriviti al nostro Virtual Club e riceverai targhetta speciale e rimozione di tutta la pubblicità, proprio tutta! Clicca Qui!

BMW Serie 3 F30/F31/F34 E-SYS non vede il gateway (no ZGW available)

Discussione in 'BMW Fai da te e tutorial: trucchi e consigli' iniziata da giusepbe, 11 Marzo 2018.

Tag (etichette):
  1. giusepbe

    giusepbe Aspirante Pilota

    21
    16
    19 Marzo 2009
    venezia
    Reputazione:
    152.912
    BMW F11 535XD
    Ciao a tutti
    vorrei esporvi questo problema col quale mi sto confrontando da un paio di giorni. Sto tentanto di collegare E-SYS alla mia BMW F31, sul mio laptop (chiamiamolo host) ho la versione 3.31 che si collega perfettamente alla macchina (il VIN viene visto immediatamente), quindi sono certo che il cavo ENET funziona bene. Fin qui tutto ok, peccato pero' che non possiedo un token valido per poter usare la 3.31 fino in fondo e quindi mi sono procurato due virtual machines, una con la 3.28 e l'altra con la 3.27, con rispettivi launcher premium. Il problema e' che l'E-SYS di entrambe le VMs non vede il ZGW della macchina. Entrambe le VMs, importate in VMWARE Workstation 11, sono configurate alla stesso modo dal punto di vista della rete, ovvero hanno una scheda di rete in bridge sulla scheda ethernet fisica dell'host, dopo pochi secondi il protocollo APIPA assegna un indirizzo IP di fallback (169.254.260.50 in un caso e 169.254.241.41 nell'altro) non ricevendo riscontro da alcun server DHCP ed entrambe le VMs riescono a pingare l'IP dello ZGW (169.254.199.99, precedentemente scoperto utilizzando il ping multicast a 224.0.0.1).
    Ho fatto vari tentativi in diversi momenti della giornata, poiche' ho letto che il modulo del gateway talvolta si inceppa, ma sempre con lo stesso esito.
    Avete qualche suggerimento?
    Grazie mille, ciao
     
  2. giusepbe

    giusepbe Aspirante Pilota

    21
    16
    19 Marzo 2009
    venezia
    Reputazione:
    152.912
    BMW F11 535XD
    Dopo una ulteriore analisi ho constatato che l'antivirus Symantec che gira sul mio laptop bloccava il traffico UDP in ingresso verso tutti gli indirizzi IP diversi da quello della scheda di rete, motivo per cui la virtual machine con E-SYS non riceveva questo traffico proveniente dal ZGW. Quindi attenzione a non commettere l'errore di concentrarsi solo sul firewall, come ho fatto io, poiche' ormai molti antivirus implementano anche le funzionalita' di firewall.
    Aggiungo come dettaglio tecnico, che magari potrebbe interessare a qualcuno, che il dialogo iniziale tra E-SYS e il ZGW avviene nel seguente modo:

    1) quando si preme il pulsante "Connect", E-SYS invia in sequenza due pacchetti UDP identici all'indirizzo di broadcast 255.255.255.255 sulla porta 6811
    2) il ZGW risponde a questi pacchetti inviando all'indirizzo dell'E-SYS un pacchetto UDP con varie informazioni sulla vettura tra le quali il numero di telaio, con il quale E-SYS popola il campo "Connection via VIN" nella finestra "Open Connection"

    Spero che questa mia esperienza possa servire a far risparmiare tempo a qualcun altro.
    Ciao
     
    A minimega piace questo elemento.

Condividi questa Pagina